IT Knowledge Base

Technical Repository

HowTo: Cisco Switching – How to create an Etherchannel LACP Port Group

Configure the Ether-channel Load Balancing Method.

EtherChannel load balancing can use MAC dresses, IP addresses, or Layer 4 port numbers with a Policy Feature Card 2 (PFC2) and either source mode, destination mode, or both. The mode you select applies to all EtherChannels that you configure on the switch. Use the option that provides the greatest variety in your configuration. For example, if the traffic on a channel only goes to a single MAC address, use of the destination MAC address results in the choice of the same link in the channel each time. Use of source addresses or IP addresses can result in a better load balance. Issue the port-channel load-balance {src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port | mpls} global configuration command in order to configure the load balancing.

Note:

The port-channel load-balance src-dst-mixed-ip-port command can change the hardware forwarding on the Supervisor and can cause interruption to traffic for several seconds to minutes until the new hash algorithm has been calculated and starts to forward the traffic accordingly. Any change in the hash algorithm is recommended during non-production hours.

1. Configure the Ether-channel Load Balancing Method.

config t
port-channel load-balance src-dst-mac
exit

2. Check the frame distribution policy configured on the switch.

show etherchannel load-balance

3. Configure LACP on the switch ports.

config t
interface port-channel 1
switchport trunk encapsulation dot1q
switch mode trunk
description MyServerManagement
exit

interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switch mode trunk
description MyServerPort0
channel-group 1 mode active
exit

interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switch mode trunk
description MyServerPort1
channel-group 1 mode active
exit

4. Server Configuration.
You will need to make sure that the server that is going to participate in the LACP port-channel configuration has its network ports configured with the correct load balancing policy and has LACP enabled.

See HowTo: Configure Windows Server 2012 R2 NIC Teaming (LACP) (article pending)



Leave a Reply