IT Knowledge Base

Technical Repository

HowTo: Configure EMC VNXe High Availability for NFS

EMC VNXe Failsafe Networking Overview
All ports on the VNXe system are configured automatically with FSN. To use FSN, you have to make sure both storage processors are cabled in the same way. There is a primary port on one storage processor and the secondary port is on the other storage processor. If the primary link fails, FSN fails over to the port on the other storage processor. The data then gets routed internally through the inter-SP communication link, so that the data can get to the storage processor that owns the storage resource.
As an example, if the resource is accessed through eth2 on SPA and this link fails, then FSN will fail over the traffic to eth2 on SPB.

Configure High Availability for NFS
To create a HA network for NFS, you can use the link aggregation feature on the VNXe system. LACP is designed to provide load balancing from a server to a large number of clients. Traffic is routed to links based on a hash of the source and destination MAC address. Link aggregation allows the administrator to bind multiple physical ports into a single logical port.

As an example, ports eth3, eth4, eth5 can be aggregation to port eth2. Link aggregation provides the following features:

  • Network traffic is distributed between the physical ports in the group. This is valid only when a large number of client connections are made to the storage system. If only one client is connected, a single aggregation link is used. If there is more than one connection, but the number of connections is small, it is less likely that the load will be distributed evenly across the aggregated links.
  • As long as there is one port in the aggregated group that is active, the VNXe system does not lose connectivity.

When configuring HA for NFS, keep in mind the following:

  • An NFS resource on the VNXe is presented on ONE storage processor at a time.
  • Two or more eth ports can be aggregated for a share folder or NFS storage server.
  • Aggregated ports combined to make a single virtual ink with a single MAC address.
  • Using stacked switches (Cisco Catalyst 3750, Cisco Nexus) enhanced the level of protection single a LACP group can contain ports that are on different physical switches in the stack.

1. Configure LACP on the Cisco Switch Stack.

LACP must be configured on the switch ports first before it can be enabled on the VNXe. We are going to configure two LACP groups, one per storage processor.

  • SPA – Eth2 – SwitchA – Interface 1
  • SPA – Eth3 – SwitchB – Interface 1
  • SPB – Eth2 – SwitchA – Interface 2
  • SPB – Eth3 – SwitchB – Interface 2

2. Configure the Ether-channel Load Balancing Method.

EtherChannel load balancing can use MAC dresses, IP addresses, or Layer 4 port numbers with a Policy Feature Card 2 (PFC2) and either source mode, destination mode, or both. The mode you select applies to all EtherChannels that you configure on the switch. Use the option that provides the greatest variety in your configuration. For example, if the traffic on a channel only goes to a single MAC address, use of the destination MAC address results in the choice of the same link in the channel each time. Use of source addresses or IP addresses can result in a better load balance. Issue the port-channel load-balance {src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port | mpls} global configuration command in order to configure the load balancing.

Note:

The port-channel load-balance src-dst-mixed-ip-port command can change the hardware forwarding on the Supervisor and can cause interruption to traffic for several seconds to minutes until the new hash algorithm has been calculated and starts to forward the traffic accordingly. Any change in the hash algorithm is recommended during non-production hours.

config t
port-channel load-balance src-dst-mac
exit

You can use this command to check the frame distribution policy configured on the switch.

show etherchannel load-balance

3. Configure Jumbo frames on the Switch Stack.

After configuring jumbo frames, you will need to reboot the switch stack.

config t
system mtu jumbo
exit
reload

4. Configure LACP for the VNXe Storage Ports on the Switch Stack.

config t
interface port-channel 1
switchport trunk encapsulation dot1q
switch mode trunk
description VNXe SPA LACP
exit
interface port-channel 2
switchport trunk encapsulation dot1q
switch mode trunk
description VNXe SPB LACP
exit
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
description VNXe SPA eth2
exit
interface GigabitEthernet2/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
description VNXe SPA eth3
exit
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
description VNXe SPB eth2
exit
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
description VNXe SPB eth3
exit

5. Configure Link Aggregation and Jumbo Frames for the VNXe.

1. Select Settings > More Configuration > Advanced Configuration.
2. Click eth2.
3. In the MTU Size list box, select 9000.
4. Click Apply Settings.
5. Select Aggregate with Eth3.
6. Click Apply Changes.

6. Test the LACP Configurations.

Issue the test etherchannel load-balance interface port-channel number {ip | l4port | mac} [source_ip_add | source_mac_add | source_l4_port] [dest_ip_add | dest_mac_add | dest_l4_port] command.

test etherchannel load-balance interface port-channel 1 ip 10.10.10.2 10.10.10.1

 



Leave a Reply